app-editors/texworks: Update to 0.6.10, fix building with qt6
This commit is contained in:
parent
404ed084cc
commit
4e88de3307
5 changed files with 34 additions and 29 deletions
|
@ -1 +1 @@
|
||||||
DIST texworks-0.6.9.tar.gz 12505487 BLAKE2B 7d1fbce67a666a7b99e093dab2e034d96a847e67a8f3c0015e34f2691d5d306bb398b1b8ddaecf8003a339a0c2e7fe946097438e0db81932f0cca597225d905c SHA512 54677205e7767f377fa66be6b2c43bec2d3c3981ea1a24eb11f45608c1cb3ddc98852c43611680273601eb8e8ae4a6095c9b9a9338ee69ef0475a43f2191551e
|
DIST texworks-0.6.10.tar.gz 11479436 BLAKE2B a6b251068c42d3ff68dfb3e5c69348abc984ace1fa9c25b3b815d22f4294931a67697ebb7abb708709be7333aee90495fdf854dea0b6625963ba35902b6aa7e0 SHA512 3f8ec187b8d6dd5f62c84cb93ac6b8d9369a8b53525518c47504fba0d1353af90d02a4b68eb38e8f623dce2f2cceae33b20917be7793f0e058864ccea7a2f8b6
|
||||||
|
|
|
@ -0,0 +1,13 @@
|
||||||
|
diff --git a/CMakeLists.txt b/CMakeLists.txt.patched
|
||||||
|
index 9682c39..43ddca5 100644
|
||||||
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt.patched
|
||||||
|
@@ -321,7 +321,7 @@ SET(TeXworks_LIBS
|
||||||
|
# -------------------------------
|
||||||
|
|
||||||
|
IF ( WITH_LUA )
|
||||||
|
- find_package(TwxLua)
|
||||||
|
+ find_package(Lua ${LUA_VERSION} EXACT REQUIRED)
|
||||||
|
ENDIF()
|
||||||
|
|
||||||
|
IF ( WITH_PYTHON )
|
|
@ -1,11 +0,0 @@
|
||||||
--- a/CMakeLists.txt
|
|
||||||
+++ b/CMakeLists.txt
|
|
||||||
@@ -297,7 +297,7 @@
|
|
||||||
# -------------------------------
|
|
||||||
|
|
||||||
IF ( WITH_LUA )
|
|
||||||
- FIND_PACKAGE(Lua)
|
|
||||||
+ FIND_PACKAGE(Lua ${LUA_VERSION} EXACT REQUIRED)
|
|
||||||
ENDIF()
|
|
||||||
|
|
||||||
IF ( WITH_PYTHON )
|
|
12
app-editors/texworks/metadata.xml
Normal file
12
app-editors/texworks/metadata.xml
Normal file
|
@ -0,0 +1,12 @@
|
||||||
|
<?xml version="1.0" encoding="UTF-8"?>
|
||||||
|
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
|
||||||
|
<pkgmetadata>
|
||||||
|
<maintainer type="person">
|
||||||
|
<email>tenno+gentoo@suij.in</email>
|
||||||
|
<name>Enno Tensing</name>
|
||||||
|
</maintainer>
|
||||||
|
<upstream>
|
||||||
|
<remote-id type="github">TeXworks/texworks</remote-id>
|
||||||
|
</upstream>
|
||||||
|
</pkgmetadata>
|
||||||
|
|
|
@ -3,15 +3,15 @@
|
||||||
|
|
||||||
EAPI=8
|
EAPI=8
|
||||||
|
|
||||||
LUA_COMPAT=( lua5-{1..3} )
|
LUA_COMPAT=( lua5-{1..4} )
|
||||||
PYTHON_COMPAT=( python3_{9..13} python3_13t )
|
PYTHON_COMPAT=( python3_{9..13} )
|
||||||
CMAKE_REMOVE_MODULES_LIST=( FindLua )
|
CMAKE_REMOVE_MODULES_LIST=( FindLua )
|
||||||
inherit lua-single python-single-r1 cmake xdg
|
inherit lua-single python-single-r1 cmake xdg
|
||||||
|
|
||||||
DESCRIPTION="Simple interface for working with TeX documents"
|
DESCRIPTION="Simple interface for working with TeX documents"
|
||||||
HOMEPAGE="https://tug.org/texworks/"
|
HOMEPAGE="https://tug.org/texworks/"
|
||||||
SRC_URI="https://github.com/TeXworks/texworks/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
|
SRC_URI="https://github.com/TeXworks/texworks/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
|
||||||
S="${WORKDIR}"/${PN}-release-${PV}
|
S="${WORKDIR}/${PN}-release-${PV}"
|
||||||
|
|
||||||
LICENSE="GPL-2"
|
LICENSE="GPL-2"
|
||||||
SLOT="0"
|
SLOT="0"
|
||||||
|
@ -27,28 +27,19 @@ REQUIRED_USE="
|
||||||
RDEPEND="
|
RDEPEND="
|
||||||
app-text/hunspell:=
|
app-text/hunspell:=
|
||||||
app-text/poppler[qt6]
|
app-text/poppler[qt6]
|
||||||
dev-qt/designer:6
|
dev-qt/qt5compat
|
||||||
dev-qt/qtcore:6
|
dev-qt/qtbase
|
||||||
dev-qt/qtconcurrent:6
|
|
||||||
dev-qt/qtdeclarative:6
|
|
||||||
dev-qt/qtdbus:6
|
|
||||||
dev-qt/qtdeclarative:6
|
|
||||||
dev-qt/qtgui:6
|
|
||||||
dev-qt/qtwidgets:6
|
|
||||||
sys-libs/zlib
|
sys-libs/zlib
|
||||||
lua? ( ${LUA_DEPS} )
|
lua? ( ${LUA_DEPS} )
|
||||||
python? ( ${PYTHON_DEPS} )
|
python? ( ${PYTHON_DEPS} )
|
||||||
"
|
"
|
||||||
DEPEND="${RDEPEND}
|
|
||||||
test? ( dev-qt/qttest:6 )
|
|
||||||
"
|
|
||||||
BDEPEND="
|
BDEPEND="
|
||||||
dev-qt/linguist-tools:6
|
dev-qt/qttools[linguist]
|
||||||
virtual/pkgconfig
|
virtual/pkgconfig
|
||||||
"
|
"
|
||||||
|
|
||||||
PATCHES=(
|
PATCHES=(
|
||||||
"${FILESDIR}"/${PN}-0.6.5-cmake_lua_version.patch
|
"${FILESDIR}"/${PN}-0.6.10-cmake_lua_version.patch
|
||||||
)
|
)
|
||||||
|
|
||||||
pkg_setup() {
|
pkg_setup() {
|
||||||
|
@ -68,6 +59,7 @@ src_configure() {
|
||||||
-DTeXworks_DOCS_DIR="/share/doc/${PF}"
|
-DTeXworks_DOCS_DIR="/share/doc/${PF}"
|
||||||
-DQTPDF_VIEWER=ON
|
-DQTPDF_VIEWER=ON
|
||||||
-DBUILD_SHARED_PLUGINS=ON
|
-DBUILD_SHARED_PLUGINS=ON
|
||||||
|
-DQT_DEFAULT_MAJOR_VERSION=6
|
||||||
)
|
)
|
||||||
|
|
||||||
use lua && mycmakeargs+=( -DLUA_VERSION="$(lua_get_version)" )
|
use lua && mycmakeargs+=( -DLUA_VERSION="$(lua_get_version)" )
|
||||||
|
@ -79,4 +71,3 @@ src_test() {
|
||||||
local -x QT_QPA_PLATFORM=offscreen
|
local -x QT_QPA_PLATFORM=offscreen
|
||||||
cmake_src_test
|
cmake_src_test
|
||||||
}
|
}
|
||||||
|
|
Loading…
Add table
Reference in a new issue